What the hell's wrong with Drupal on WAMP?

Look at the top keyword searches that bring people to my site, according to Google Analytics:

  1. tom geller (O.K., that's a gimme.)
  2. wamp drupal
  3. drupal wamp
  4. (content targeting)
  5. drupal on windows
  6. drupal windows

Further, about one in five requests for support sent through my site's contact form is WAMP-related.

So -- what's the story? Is it that WAMP is hopelessly messed up? Is there a vacuum of relevant information out there? (My Running Drupal on Windows using WAMP article is Hit #4 on Google.) Have you had problems running Drupal on WAMP? Does the Acquia Drupal stack installer for Windows help?

Blog category: 

Comments

if users are posting support requests to you, then you have to know the answer..

I spent 4 days getting this combination to work then I broke It yesterday. I am so tiered of working on it I have just put that project on hold. I think I need to work on things I can make work with out so much effort.

most noobs are trying to figure out how to install drupal on their windows computer. so they have to learn about wamp and how to install drupal on it. wamp works fine as a development environment and really isn't that difficult to set up. but if the whole environment is new to you, you're going to have to do some research to figure it out.

Maybe you can start explaining with what's not working for you then? Setting up WAMP is probably one of the simplest things a developer (on Windows) ever has to do. I don't get the impression that there is any thing wrong with WAMP ... ...

It's because more people are deploying Drupal on WAMP and WIMP stacks, and because on Drupal.org there is a horrible dearth of organized, actually helpful information about running Drupal on Windows, whether WAMP or WIMP. Mostly, when one tries to find documentation, seek help in IRC or look to the forums, one of two things happens: 1) Some variant of the "I hate Windows" thing - eg "I wouldn't touch Drupal on Windows with a ten foot pole. Sorry, can't help you," or "only NOOBS use Drupal on Windows"... 2) The searcher finds 10,000 unanswered threads on how to do some simple thing, so they look outside Drupal.org for answers. It's no fun running open source software without the benefit of the open source community [you might as well run Joomla]. Nonetheless, huge numbers of businesses run Windows, so a growing number of shops really would like to deploy on WAMP or WIMP and take advantage of some of the economies to be found there. MS is doing very interesting things with PhP on IIS7 and is even [gasp] attending DrupalCamps and DrupalCons. So, maybe your site is one of the few places WAMPY/WIMPY Drupallers can go for information, NOOBs or not. Thanks for putting the information out there. Someone's gotta do it.

This comment is spot on, especially the 2nd to last sentence. I'm a reasonably advanced Drupaller who normally does all of his development on a combination of Linux servers and a MacBook, but for July and August I have (for reasons not worth getting into) been forced to work on a PC running XP, without access to a Linux server. I've tried WAMP and DAMP and have been pretty amazed, in both cases, with how little structured support info is available online AND by the degree of performance problems I've run into.

The people who solve their problems need to contribute to documentation. Documentation is contributed by users. If people who have solved their problems do not contribute, then there will continue to be a lack of documentation.

Hi all, I'm glad it's not just me. drupal on wamp vista is very slow. in fact about 10x slower than joomla on my vista laptop. so slow I'm moving back to joomla because despite what you read about how fast drupal is. In reality on my laptop p8600 with 3Gb ddr2, it's slow. On top of that, developing in drupal is slower than developing in joomla. so, slow on top of slow == frustrating. and I totally agree, open source software with no open source community support is like diving into a black hole. No one really cares. so after spending 6 months catching up on drupal, I think I'll move back to joomla and develop and deploy my site within 3 weeks, functionality, graphics, templates, user profiles, business directory, job board all done.

Wow, that's really unfortunate that you had that experience. If you still want to give Drupal a shot, consider trying XAMPP: I haven't tried it, but have heard good things about it. You could also try the Acquia Drupal Stack Installer for Windows, but I don't know whether (or how) its WAMP stack is different from the WAMP you're currently using. Good luck!

time to write a nice article about the Acquia Stack Installer. http://acquia.com/downloads

I wrote that article when Acquia DAMP first came out: "A boon to beginners: the "Acquia Drupal stack installer" (DAMP)".

I had a serious headache setting up drupal on wamp with http request fail errors. It took some time to discover the http request fail reset module to bypass this problem and until I had drupal slowed to a crawl. I've never had any similar trouble installing drupal with a webhost, so presumably the issue lies with wamp. For all it's flaws though, wamp is still the least painful way I've found to run drupal on windows.

drupal runs ok on xampp use it.

I actually switched from XAMPP to WAMP a few weeks ago and love it. The migration was simple - only taking about 10 minutes. True I have a lot of experience in setting up LAMP servers, so that's a big plus for me. A few things I can think of that might cause problems: - mod_rewrite is disabled by default, so people might have problems getting clean urls to work - there is a difference in paths between Windows and *nix setups. That can lead to some confusion. - WAMP ships with PHP 5.3. Drupal isn't 100% 5.3 friendly. Best bet is to download PHP 5.2.9.2 and use that instead. If you are using XDebug, then use PHP 5.2.6 since there are problems with PHP crashes and XDebug in Windows on PHP>5.2.6. To the last point remember if you want to change your php.ini then edit wamp directory/bin/php/{version}/phpForApache.ini. That file is copied over by WAMP when changing PHP versions. Another thing to keep in mind is that WAMP sets error_notices to E_ALL. A lot of modules out there still throw notices, so go best to change it to E_ALL & ~E_NOTICE. Until D7 is out in the wild for a while and more modules move to full PHP 5 only support, this will probably be needed. And for the serious developers out there who want to use their own domains I highly recommend installing Treewalk DNS. I have mine setup so that the .devel TLD is my system. I can then quickly setup unlimited sites, and even do wildcard subdomains - great for testing multisite stuff. This combination of stuff works great on my Vista 64 system.

This is an incredibly helpful comment, and I'm going to point people at it from now on. In fact, I linked to it from an earlier post, Tips: Running Drupal on Windows using WAMP.

You have a good point about PHP 5.3. Another option is install Wampserver 2.0h (the latest version is 2.0i). Wampserver 2.0h is available on the sourceforge page for Wampserver (http://sourceforge.net/projects/wampserver/files/WampServer%202/WampServer%202.0/WampServer2.0h.exe/download). Also, mod_rewrite is easily enabled through the Wampserver menu in the system tray.

If someone doesn't contribute a page to the drupal.org handbooks, then it will continue to leave users coming here.

Writing and organizing are two different skills. It's one thing to write the information, as people have done here; it's another to: (a) figure out how Drupal.org's documentation works (b) find an appropriate place on Drupal.org to put the information, and (c) integrate it with existing information so it's not redundant or contradictory. That second part takes a LOT more time and attention, IMHO. If you disagree, then take the "easy" part yourself, and go for it!

On Windows Vista (and presumably server versions thereof), Drupal may not install because PHP 5.3.1 can't find localhost.

I can second the simple XAMPP setup: 1) Download XAMPP (use google to find this) 2) Install XAMPP 3) Turn on the Server 4) Navigate to localhost/phpmyadmin 5) Create database 6) Download Acquia's Zipped version of Drupal 7) Copy decompressed files inside the "htdocs" of the XAMPP application folder (you could create a folder if you like) 8) Access "localhost" or "localhost/newsubfolder" 9) Install Drupal Nothing too complicated. Or you could use Acquia's Stack installer, though that has errored out on me once or twice.

I use WAMP on my laptop for all of my development, and I've only had one real issue. It seems like admin/build/modules takes a really long time to load. I've tried messing with the hosts file, as I'd heard that the IPv6 configuration that is on by default in Vista could cause problems, but it didn't seem to help. At this point, I'm chalking it up to the rest of my environment being what it is, and that there is a *lot* of stuff that happens on that page.

I had the same problem and it was resolved by changing the MySQL storage engine from Innodb to MyISAM. You can see my blog post about this at http://kswantech.com/blog/slow-menu-rebuild-drupal.

because it finally has a Mac version that works. That way my two development environments (a windows & mac machine) are the same. But then I'm still slightly different from staging and production. So I've been tempted to try to use VMware or VirtualBox so I could run a virtual Linux server that very closely replicates my production environment.

How about appserv? I've used it on windows with no problem :)

I see complaints about documentation and forum replies dismissing help for people using Windows. The same happens to Linux and Unix beginners and is the biggest single roadblock to people using Linux for Web development. Installing Apache, MySQL, and PHP on your existing Windows netbook, notebook, or workstation is far easier for Web developers already on Windows. The various packages of Apache, MySQL, and PHP sometimes work and sometimes do not but are hard to fix at the start of a class because there are so many variations of the packages each with different problems and each reacting differently to the various versions of Windows. To diagnose the Apache part of a package install, you end up installing Apache by itself. The same thing happens with MySQL then PHP. When the package works, the package interface is different to the cpanel you use on your Web server or VPS. Ubuntu has the best support for beginners but a search of Ubuntu or any other Linux distribution frequently brings up documentation showing how to use an incompatible version from 2002 or earlier. Converting an old computer to Ubuntu usually works without resorting to the outdated documentation but converting a modern computer often runs into trouble, leaving the user wishing they had simply installed Apache, MySQL, and PHP direct into their Windows machine. The Unix/Linux pages are full of unexplained commands that have to be entered in the Unix DOS box. Try telling a Windows user to revert to the 1970s and DOS commands. Windows looks really good compared to the documentation for Linux and Unix. One argument for converting to Linux is that your Web site will be hosted on Linux. Who cares? The vast majority for beginners use a hosting package that includes cpanel. They do not see the dreaded Unix DOS box. Based on students with notebooks, a straight installation of Apache works in Windows with the Windows firewall and virus checkers turned off. The Windows firewall and virus checkers spoil almost every installation of everything and students are used to switching them off. With those items off, MySQL and PHP slip in as smooth as cholesterol into an artery. Vista and Macs have strange security arrangements where things randomly refuse to work in class and they have to take the machines back to the shop or whoever installed the operating system. My suggestion for the future, when Webmin and related packages can do everything that cpanel does, is to set up your local machine, using your existing operating system, and your hosted VPS with exactly the same lineup of Apache, MySQL/PostgreSQL, PHP, Webmin, the other mins, Drupal, dotProject, and WebERP/XRMS. We can then use one Web interface for everything and forget Windows, Linux, Unix, the perpetual Gnome/KDE fight, the annoying Mac differences, and the dreaded Vista. Of course we have to make all those web applications change to use one themeing system so they all use the same theme because then all the buttons will be the same. Quick! Look out your window. Is that a flock of winged piglets up in the sky?

Wow, great comments. So let's say that open-source projects generally have poor documentation. How can that change? My solution is simply stated: More editors and content admins, fewer writers. That's how you both clear out obsolete information and refine what's there.

I sucesfully install durpal 6.2 in my machine using wamp: 1.Creat a database say:my_site. 2.run durpal by http://localhost/drupal/install.php 3.Select the language when error comes 4. Just rename default.settings.php to settings.php in sites\default hit refresh 4. In settings.php $db_url = 'mysql://username:password@localhost/databasename'; by $db_url = 'mysql://root:0205039@localhost/my_site';save it and hit refresh here 0205039 is my pass. 5. complete the next step............. N.B. Theres may be an error shown that Unable to send e-mail just ignore it! Thats all!!!!!! Use Drupal on wamp Thank you

Thanks for your step-by-step instructions -- I'm sure they'll help someone. It seems that people are having problems that aren't solved by your procedure... but I'm glad you took the time to put it all down in one place.

I installed Drupal on WAMP under XP, got past all the idiosyncrasies such as using PHP 5.2, it was working, then...literally the Blue Screen of Death. Windows just would not boot - kept restarting. I eventually booted to a Windows disc and ran chkdsk, which found "minor errors". I was able to boot XP, but no Windows services worked. Really. Update, COM, Installer, nothing. Tried doing a repair install (3x) to no avail. Ended up having to do a complete reinstall (even formatted the HD to be safe) and now it seems to be fine (about a week now). I want to get working with Drupal, and I have been advised by various developer colleagues that WAMP is one of the best to use, but now I am a little afraid. I'm not a techie, but neither am I a complete noob. I'm comfortable in Linux, but this is is being set up for a friend who insists on Windows. Any ideas and/or comfort that it was a one-time thing are greatly appreciated.

I've never used it myself, but I'm optimistic that DAMP (the Acquia Drupal AMP stack installer) is more stable. It appears to be built on WAMP, and I don't know what "tweaks" they worked in to the WAMP part. But they seem to have put a lot of thought into it, and it includes Drupal! If you do try it, let me know how it goes... I'd really like to get some results from the field.

DAMP is built on our own packaging / build of Apache, MySQL and PHP and of course our custom control panel. It is not built on top of another stack package. - Chris VP Engineering, Acquia

Boy, is my face red! I made the assumption based on the superficial similarities of the two. I'm sorry for the mistake, and won't make it again. Thanks for the correction.

As said earlier there are two errors that WAMP throws at you that are not at all obvious. The fragmented nature of Drupal.org Documentation makes it quite frustrating to use. A good example of organized documentation would be the Wordpress Codex or the Drupal API. A Google search brings better results than the Drupal Documentation. When you first start try to install Drupal 6.2 on WAMPserver2 two there is a nice repeating background of cryptic errors. Discouraging! To continue: Download PHP 5.2.9 from WAMPserver website Change from PHP 5.3 to PHP 5.2.9 on Wampserver Install Drupal without errors. Yeah! After the installation you cannot select Friendly URLs Turn on Apache mod_rewrite Friendly URLs can be turned on now After the setup and install is finished go ahead and turn on PHP 5.3. I haven't had problems with Drupal 6.2 and PHP 5.3 (including core updates)except for the initial install. "Learn by the Drop" covers these initial issues.

drupal won' work on php 5.3 it works only in php 5.2.x

I got tired of all the problems of running drupal on xampp amd wamp. So, I searched and found the perfect solution: "Mowes_portable"

Thanks for the info! I didn't know about mowes_portable. The link is: http://www.chsoftware.net/en/useware/mowes/mowes.htm (for the English version, anyway).

I am installing Drupal 6.14 using WAMP on a Windows Vista machine and following the instructions in the Lynda.com Drupal Essential Training Release Date 8/08 I have followed the steps several times and even went to the effort of uninstalling WAMP (from my previous lessons on Joomla) and then reinstalling it. Specifications in WAMP indicate that I am using localhost SQL Server version 5.1.36, Apache 2.2.11 PHP/5.2.0, phpMyAdmin Version 3.2.01 I took the following actions: 1. Opened PhpMyAdmin and created drupal database - successful 2. Downloaded Drupal 6.14 to mydownloads 3. Opened with WinZip 4. Extracted files to a folder in mydownloads named Drupal-6.14 5. Opened C:\wamp\www folder 6. Deleted Index.php file - folder is empty 7. Selected 22 items from drupal-6.14 folder - 7 folders and 15 files and copied 8. Pasted 22 items into C:\wamp\www folder 9. Returned to web browser and removed phpmyadmin leaving only localhost, pressed enter. That opened a browser with multiple lines of the following message: Deprecated: Function ereg() is deprecated in C:\wamp\www\includes\file.inc on line 902 At the bottom of the screen (after what appears to be several hundred lines of the above message, there was the drupal screen. I selected English language and had the same instance of several hundred lines of the message above before displaying the instructions to create the settings.php file. Each time I had the same several hundred messages coming across. I finally did get through to the point that I had the new site set up. I am wondering how many other issues like this I may run into. Thanks, Don

Hey, Don -- thanks for writing in such great detail. I'm really not an expert at WAMP: In fact, I don't even own a Windows computer. I hope that someone else in this forum can solve your problem if my suggestion, below, doesn't help. You write: Selected 22 items from drupal-6.14 folder My instructions were in error. Drupal's home directory includes an invisible file, ".htaccess", which isn't copied when you do it this way. The better thing to do is to rename the entire Drupal folder "www" and use it to replace C:\wamp\www. (I'm guessing you could also change a setting in WAMP to point at that folder regardless of its name and location, but don't know how to do that.) I wrote about this last year, but it's pretty well-hidden. Sorry again! Anyway... did this fix your problem?

I'm viewing the Drupal course on Lynda.com. ONCE I figured out I needed to uninstall IIS, all went smoothly with the installation of WAMP (used the 2.0h version based on a comment above titled PHP 5.3) and Drupal. Note: I temporarily turned off my anti-virus software as well. For people who need to run both IIS and Apache concurrently, there are methods to do this. The key seems to be that you need to set them to use different ports. This is a page that has some info: http://www.wampserver.com/phorum/read.php?2,57798 . I am sure there are others.

Very interesting -- thanks for the tip! I'll be interested to hear whether others are able to solve their WAMP/Drupal problems this way.

Just a quick update for anyone subscribed to this thread. A recent dustup with Microsoft alerted me to the "Microsoft Web Platform Installer", and this page devoted to installing Acquia Drupal on Windows using it. Reports back, anyone? Does it create some sort of horrible lock-in to Microsoft's "Web platform"? Does it damage any other installations?

Thanks Tom for the update here -- The Web PI that installs Drupal should not "create horrible lock-in" and will not damage other installations. In fact, it will give you a configured, ready to run Drupal instance on top of Windows and IIS without a lot of work. It will identify the needed components, the proper versions, the right configurations, ask the right questions, fetch those components and install them on your machine for you. Would love to hear about your readers experiences. Thanks, Brian Goldfarb Director, Web/UX Platforms Microsoft Corporation

I attempted to set it up (Windows 7), and the installation hung (left it overnight) on installing MySQL. I had to kill the installer, which left me with a partially installed MySQL instance. Bah! I actually found the installer UI a bit difficult to use. We're using Drupal (not Acquia), but there wasn't a simple option to install IIS, MySQL, and PHP. I could find options to install SQL Server, but not MySQL. This utility is certainly a step in the right direction, as Windows is a real pain for most web development. I'll be very happy when setting up local instances on Windows is as easy as it is on OS X and Linux :)

http://apache2triad.net/ I can't believe that that's not mentioned once as a good way to install Drupal on windows.. It installs & configures all services needed to run a WAMP & a bit more. Install it and you can just follow the normal doc's on installing Drupal I do agree with the comments though of complex & bloated documentation on Drupal, It's large and there's legacy support that's poorly marked at times you read the whole thing only to get to the end to find it was for 4.62 or earlier, unless your always looking for phishing attacks on yer documentation o_O. It is however a community that for the most part stays on topic and doesn't go bashing typos that helps dyslexics (like me) or ESL (English as a Second Language) people feel a bit more free to talk code & not semantics. My personal experiences are however grate with WAMP running on my netbook (yes netbook) with the above mentioned install. I use it to do Note taking & Theming when I'm on the go, and scare stewardesses when I'm on a plane thinking I'm on the web (yes I have been told to stop going online at 30k feet). And to the blue screen of death, that sounds like something other than php, it could have been, however, it sounds more like a corrupted registry or hard disk/component failure. When a service craps out it should just take itself out not shower you with the blue. It's come along way since 95's BSOD hell.. I still prefer being able to control shift backspace in GNOME though *shrug*.. but then I wouldn't have notepad++, and a few other tools.

I wasn't aware of Apache2Triad. Add another one to this ever-growing list of solutions!

Are you using apache2triad for the stack on your netbook? I've tried Acquia's app and it seems to run really slow. I've tried XAMPP which seems to work really quick with Drupal 5 but Drupal 6 seems to drag on when rendering pages. I know I'm using a netbook (blah blah blah) but I would've thought that I could run a simple Apache, MySQL, and PHP stack with Drupal for personal learning/training/themeing etc. without much of a problem.

Apache2Triad appears to be discontinued. Since I come from the Windows world, Drupal looked like an amazing pain to set-up from scratch. Luckily, I found TurnKeyLinux.com's pre-configured VMware appliance. It got me hooked on wanting to use Drupal and finally suggest it as our new corporate Intranet CMS to replace our antiquated Lotus Domino based site. We looked at SharePoint, but the licensing is confusing, irritating, and costly, and was ultimately a turn-off to the powers in control of funding projects. The only positive it has is flawless Active Directory integration, which none of the non-Windows solutions seem to have. Even our ancient Lotus Domino site has decent LDAP integration. Unfortunately, I've had nothing but problems getting Drupal to work reliably on Windows. I've also had no luck getting any of the LDAP modules to communicate with our Active Directory. I researched the LDAP options and found that you can (attempt to) implement authentication at each level of the stack, yet nobody seems to have a "best practice" way of accomplishing it. I wasted many hours sifting through the drupal.org forums to try to make sense out of it. Some require an Apache plug-in, some require a PHP plug-in, and some require IIS instead of Apache for SSO pass-through authentication... It just starts to look like an aimless hack. Today, just before I left work, I had the DAMP installation running on a fresh installation of Windows Server 2003 R2 (32 bit). It appeared promising until I logged into Drupal from my laptop (Win7Px64IE8). For some reason, the refresh stops short and requires a manual refresh after login?!? I don't have that problem with the Linux installations I've been testing. It almost pains me to admit, as a "Windows guy", that Linux could better than Windows for something so seemingly simple. Am I just wasting my time trying to use a configuration with which Drupal was never designed to work? I'm considering recommending to my director that we drop our guard and admit "just one" Linux appliance VM into our, otherwise, all-Windows network.

Hi, Anon. I wish I could help you, but I know *nothing* about LDAP, and in fact almost never use Windows at all. I'm hoping someone else following this thread can help. Anybody?

I first started using WAMP version 2.0c about two years ago, and experienced no problems. A couple of months ago I upgraded to version 2.0i - and that's when the problems began. I have been experiencing the volumes of PHP errors reported above, plus every now and again (and sometimes, very frequently) I get a Windows message telling me that the Apache server has stopped working. I tried DAMP and MoWeS, but PHPMyAdmin did not work with DAMP, and I kept getting the "Apache not working" message with MoWeS, so I have gone back to WAMP. Version 2.0i includes PHP 5.3.0 by default. Following advice included in a comment above, I downloaded and installed PHP version 5.2.6 You can do this by selecting, from the WAMP icon menu on the toolbar: PHP > Versions > Get More ..., which takes you to the WAMP website and allows you to select the version that you want. Once installed, PHP > Versions shows the versions that are available and the the one that is active (ticked). Select the one that you want to use and WAMP reboots itself (the icon turns yellow, then comes back to white). Since using version 5.2.6 of PHP, it seems that my problems are solved. One point to note. When I try to import an SQL dump of a database via PHPMyAdmin while PHP 5.2.x is running, I get a "file too big" error; but when I switch to PHP 5.3.0, it imports without any problems.

Thank you for that extremely useful overview! I'm sure it'll help lots of people who find this page. Cheers, --Tom

This is probably related to all versions of Windows but has anyone solved the problem with getting xdebug to integrate between Eclipse (or any of the other IDE's for that matter). DAMP was fantastic. I had it up and running in 5 minutes (after spending 2 months of hell developing at a snail's pace with wampserver and drupal). BUT, if you want to do anything more complicated than string a few modules together...it looks like you will be wasting your time. Look at Robert Douglass's comment at the foot of this page: http://acquia.com/blog/xdebug-komodo-and-acquia-drupal-stack-installer Looks like this showstopper even has the guys at Acquia stumped!?

What's wrong with you? if you're gonna google bomb this, you'd better have answers.

These days, my answer is to use DAMP. That's the recommendation I'll be making in the upcoming Drupal 7 Essential Training videos from lynda.com. (And I think you're a bit confused about what "Google bombing" is....)

Per your recommendation on the Lynda.com video, I checked into the DAMP stack. For the record, I have been SUCCESSFULLY using WAMP for several years and have NOT had anything like the problems you have described though for sure WAMP needs to be tweaked to run DRUPAL per their requirements. I have to say, WAMP has NEVER beat me over the head with requests to subscribe to their so-called support services and I don't NEED all the STUFF they have added that just pollutes the distribution as far as I am concerned. I dare say, not everybody needs or wants the Acquiacentric business model and I REALLY, REALLY dislike being slapped with a subscription request, EVERYTIME I do anything in the DAMP stack. I have actually built a stack from scratch with the lastest components and had very little problems with 1. Getting all the parts to run, and 2. Optimizing the stack to run DRUPAL and NONE of the unsolicited BS from the installed components. It's NOT Rocket Science, frankly!

Hi, "Unimpressed". I completely understand your feelings: If you leave Acquia Drupal installed, it nags you relentlessly to sign up for the "Acquia Network". Fortunately, it's not so hard to replace Acquia Drupal with "core" Drupal, which doesn't do that. I show how in Drupal 7 Essential Training; written details are on Acquia's site at http://acquia.com/documentation/acquia-drupal-stack/import . (If the stack *didn't* have this feature, I'd never have mentioned it.) Good luck!

I just installed the latest and greatest DAMP and it contains latest stable 6.20 which is more what I expected but I also discovered that the "Subscribe Today!" silliness is a module that can be turned off! What a pleasant surprise. I disabled the whole module and like magic the offensive stuff was gone... fyi I am troubled, however, that Drupal 7 is no where to be found on their downloads... Also, the amount of good info on the Drupal Site itself in regard to specifically v7 is troublesome and annoying. With all the hype they have generated about it, you would think that they would have a LOT of new cool stuff but that doesn't seem to be the case. I was thinking to "shelve" my limited Drupal 6 knowledge and immerse myself in v7 but I feel like that's not a reasonable strategy at this point, the number of "finished" i.e. production mods and themes is pitiful. When checking, I found that most were either alpha or beta releases with huge gaps in time that nothing is happening with the v7 development and a huge number of "unknown support status" ... It all gives me a spooky feeling about whether or not its (v7) is soup yet though I have to admit that I am not finding a lot of bugs that haven't already been reported. I think that slow adoption by the community may be a real problem for getting v7 off the ground in a serious way. I have to admit that I am a bit skeptical now from what I am seeing ... best regards, m

Hey, "Unimpressed". I've been building out a site in Drupal 7 and finding it hard because of missing functionality and lingering bugs. But it's MUCH better than it was for Drupal 6, due in large part to the #D7CX movement. As for Acquia not having "core" Drupal on their site: I have no problem with that. Why should they? They're not obliged, and it would just confuse the issue. I think your other concerns are mostly valid. (I've written about my problems with Drupal.org documentation before.)